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1. HACCP Terms of Reference 
HACCP Starts with a HACCP Team (as I am sure you will know). It also starts by describing the 
Product or Process under study and the Scope of the HACCP Study and the recording of a number of 
other pieces of vital information. These Terms of Reference are essential to a well-balanced HACCP 
study and to a HACCP system that will give the best value to your organisation. A full list of the HACCP 
Terms of Reference is given below. 
 
1.1 The name and summary description of the Product or Process being analyzed under HACCP. 
1.2 The Scope of the HACCP Study, i.e. whether the study is to apply to Microbial, Chemical or 

Physical risks and whether Quality issues are to be considered. 
1.3 The Point of Safety, i.e. at what point does the HACCP study assume the product to be safe having 

been produced in full compliance with the HACCP study. This could be for example, “after cooking”, 
“after packaging”, “after delivery”, “after storage”, “before use by date”, etc. 

1.4 A full description of the Product or Process including all relevant technical details such as the pH, 
water activity, storage conditions, etc. 

1.5 The use for which the end Product is intended. Here the HACCP Team would highlight any 
susceptible groups in the population, e.g. old age persons or very young children. 

1.6 Finally the HACCP Team itself must be recorded in the system together with relevant details of their 
qualifications and / or experience that means their expertise is of value to the HACCP study. 

 
All of the above functions are accessible on the HACCP Terms of Reference form. The HACCP Terms 
of Reference form can be displayed by selecting “HACCP Terms of Reference” from the Main Menu 
after login. Alternatively, HACCP Terms of Reference can be access from both the Flow Diagram and 
HACCP Instruction Card screens on their View menu’s. 
 
The HACCP Terms of Reference form is shown below: 

 

Enter the details as 
you wish to see 
them on the printed 
report 



The HACCP Terms of Reference screen has the following features. 
 
Menu: 
File 

 - Save – Saves the current Terms of Reference against the selected HACCP Study. 
   - Exit – Exists the application. 
View 

- Flow Diagram – switches to the Flow Diagram screen 
- HACCP Instruction Cards – switches to the HACCP Instruction Card screen 
- Main Menu – switches to the Man Menu screen 
 

Reports 
 - Table Format – displays the Report Printer screen. 
 
Screen controls: 
Select Study – Displays the selected HACCP study for editing its Terms of Reference. 
 
New Study – Allows the creation of a new HACCP Study and the entry of its Terms of Reference. 
 
1.1 Procedure for creating a new HACCP Study 
A HACCP Study can be created from either Flow Diagram or HACCP Instruction Card screens by 
simply entering a new name and saving the Flow Diagram or HACCP Instruction Card. However, the 
best place to create a HACCP study is at the HACCP Terms of Reference screen. Follow the procedure 
below in order to create a new HACCP Study. 
 

1. Start the system and login. 
 

2. Click on ªHACCP Terms of Referenceº at the top of the Main Menu list. The HACCP Terms of 
Reference screen will now display. Notice that it does not show any study and the ªSelect 
Studyº drop down list is set to ª<Select>º. Note also the ªNew Studyº button to the right of the 
drop down list. 
 

3. Click on the ªNew Studyº button and notice that the ªSelect Studyº drop down list changes to a 
ªNew Studyº textbox. The ªNew Studyº button will also change to ªSave Studyº. 
 

4. Enter in your new HACCP study name (once this is entered it cannot be changed) and click the 
ªSave Studyº button. The new study will be created and will now appear in the drop down list for 
ªSelect Studyº which now will appear. 
 

5. Next, select the newly created HACCP study from the drop down list. If any information is 
present on the screen this will now disappear. 
 

6. Finally enter all the information you wish to in each Tab of the screen. The information displayed 
in the printed output consists of a page for each entry. The Title of each entry will be the 
ªHeaderº as shown on the form and the information below each Header (i.e. the Bodyº) is 
displayed immediately under each Header. 
 

7. When you have entered all the information about the HACCP study that you want, click on the 
ªFile – Saveº menu to save you entry. 
 

8. To view and print your entered information click on the ªReports – Table Formatº menu and then 
select ªTerms of Referenceº on the screen and click ªDisplayº. This will show you all the 
information on the screen (use the navigation arrows at the bottom of the screen to see all 



pages / entries). This report can be printed and included in any paper copies of the HACCP 
system. 



2. Creating a Process Flow Diagram 
 
2.1 The File Menu - Summary 
 

 

·  New - Start a NEW Process Flow Diagram. 
·  Open - OPEN an EXISTING Process Flow Diagram (from the 

"saved" HACCP Database). 
·  Save - SAVE the current Process Flow Diagram (to the "saved" 

HACCP Database). 
·  Save As.. - SAVE the current Process Flow Diagram as a NEW 

NAME (to the "saved" HACCP Database). 
·  Save As Web Page.. SAVE the current Process Flow Diagram 

AND its underlying HACCP Instruction Cards as a set of 
interlinked Web Pages. 

·  Print.. - Send the current Process Flow Diagram to the 
PRINTER. 

·  Print Preview - See what the current Process Flow Diagram 
will look like when it is printed. 

·  Exit - Leave the program 
 

 

2.2 The Edit Menu - Summary 
 

 

·  Cut - Remove the currently selected text. 
·  Copy - Copy the selected text to the "Clipboard". 
·  Paste - Paste in the text from the "Clipboard" 
·  Delete Current Control - Deletes the currently selected control 

on the Process Flow Diagram (this option is only available if a 
Flow Diagram component is selected), e.g. if a "Process Step" 
box is selected, it will be deleted, if a Flow Diagram "Line" is 
selected it will be deleted. 

·  Clear Current Page - Clears all controls on the currently 
displayed page of the Process Flow Diagram. The page is not 
deleted but simply cleared ready for new input. 

·  Delete Current Page - Physically deletes the current page from 
the Process Flow Diagram. 

 
Note : None of the changes above will be permanent UNTIL the 
Process Flow Diagram is SAVED. 

 



2. Creating a Process Flow Diagram 
 
2.3 The View Menu - Summary 
 

 

·  HACCP Terms of Reference ± Selected when in HACCP 
Terms of Reference view. 

·  Process Flow Diagram - Selected when in Flow Diagram 
View. 

·  HACCP Instruction Card - Select to move to HACCP 
Instruction Card view  (i.e. to switch to it). 

·  Main Menu - Select to go to Main Menu view (i.e. to switch to 
it). 

 
Note : When you move between different " views"  your data remains 
loaded and will be there when you return, unless you clear it. 

 

 
2.4 The Insert Menu - Summary 
 

 

·  Add Page - Add a new page to the Process Flow Diagram. 
·  Title - Put a title box on the currently displayed page. 
·  Process Step - Put a Process Step box on the currently 

displayed page. 
·  Line.. - Put a "Down", "Left", "Right" or "Up" Line on the 

currently displayed page. 
·  Text Label - Put a Text Label on the current page. 
·  Page Connector - Put a Page Connector on the current page. 

 

2.5 The Format Menu - Summary 
 

 

·  Font - Select a particular Font (default is "Arial"). 
·  Process Step Foreground (Text) Colour - Select a 

Foreground (Text) Colour for the currently selected "Process 
Step" box, "Text Label", "Title" or "Page Connector" 
components. 

·  Process Step Background Colour - Select a Background 
Colour for the currently selected "Process Step" box, "Text 
Label", "Title" or "Page Connector" components. 

·  Line Colour - Select a colour for the currently selected Line. 
 
Note - The above functions will only be available for use when the 
appropriate  item(s) are selected on the page. 

 



2. Creating a Process Flow Diagram 
 

2.6 The Mode Menu - Summary 
 

 

·  Edit Mode - When in this mode the user can edit and change 
the details on the currently open Process Flow Diagram. The 
selector is coloured GREEN when in Edit Mode. 

·  Navigate Mode - Enables the user to "click" on a "Process 
Box" and, if the HACCP Instruction Card exists, takes the user 
to The HACCP Instruction Card screen and opens the relevant 
HACCP Instruction Card. If the HACCP Instruction Card does 
not exist it loads up the Process Name (from the Process Title 
on the Flow Diagram) and Title (from the box that was "clicked") 
into a blank HACCP Instruction Card so that Hazard analysis 
can take place. When in this mode the user cannot change the 
Process Flow Diagram's text and the selector is coloured RED. 

 

 
2.7 Speed Icon - Summary 
 
The speed icons are intended to help complete common tasks more quickly and are as shown in the 
diagram. 
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2. Creating a Process Flow Diagram 
 

2.8 Procedure for Creating a Process Flow Diagram. 
 
1. Start up the program and click on "Process Flow Diagram", 
 
2. Note that the "drawing space" is clear so you are ready to draw a new Flow Diagram, 
 
3. First, INSERT a Title, either by using the "Insert" menu or by clicking the speed button on the left of 
the screen under "Components". Type in a valid name, ensuring that you DO NOT USE A NAME THAT 
ALREADY EXISTS. (You can check this by using File>Open, but will be warned before saving your 
work anyway.), 
 
4. Next, INSERT a Process Box , again, either via the "Insert" menu or by using the appropriate speed 
button. The Process Box may be "dragged" about the screen to the position you want to place it by 
moving the mouse over its edge and pressing the mouse down and holding it down while you move the 
Process Box. When you have the Process Box at its desired location simply let go of the mouse button, 
i.e. "drop" the Process Box. Enter in the Step Number, Step Title, Temperature and Time Range for the 
product at that step. Colour code the Process Box as required by using the Format menu functions. 
 
5. INSERT a "Down", "Up", "Left" or "Right" Line as required and colour it (if required) using the Format 
menu. Any of the Lines can be "dragged" and "dropped" in a similar manner to the Process Box above, 
but you must "click" directly over the center of the line in question. The Lines can be "drag" re-sized by 
clicking directly over the arrowhead and "dragging" the mouse to the desired position. 
 
6. When you eventually run out of space on the page and can no longer add any further Flow Diagram 
components add a Page Connector in the same manner as above and colour it as required using the 
Format Menu. 
 
7. Join up all your Process Boxes, Lines and Page Connectors as required. 
 
8. Now, via the INSERT Menu, Add a Page and add more Process Steps, Lines, etc, as required. 
 
9. Regularly Save your work and Preview it to see what it will look like when printed. 
 
10. When you have finished creating your Process Flow Diagram and you have saved your work you 
can then change to "Navigate" mode by selecting as such in the "Mode" menu and then click on a 
"Process Box" to take you to a blank, HACCP Instruction Card. Note - It is possible to create HACCP 
Instruction Cards without a Flow Diagram but doing the Flow Diagram first is the recommended method 
of carrying out your HACCP Study.



2. Creating a Process Flow Diagram 
 

Tutorial 1 - Creating a Process Flow Diagram 
 

The following tutorial will demonstrate most of the key "Diagramming" features of the Process Flow 
Diagram screen of HACCP Now. 
 
In order to create the diagram, refer to the menu summary in the previous pages. 

 
Scenario 
You have a visit from a major customer. They want to see a Process Flow Diagram of your main 
product that you supply to them. Using the HACCP Now software produce a simplified Process 
Flow Diagram. In your example you should have the following: 
 

·  A Title 
·  At least FIVE Process Steps on Page 1 (all with different coloured text and 

backgrounds) and at least TWO Process Steps on Page 2. 
·  Colour Coded Page Connectors, to cross-reference between pages. 
·  Examples of each Line type (two of which are colour coded). 
·  Demonstrate TWO uses of a Text Label. 
 

When you have finished save the Process Flow Diagram and then select "File>New" to clear it 
and then "File>Open"  to load the newly created Process Flow Diagram back in again. This will 
prove that you have saved your diagram and illustrate how to "Open"  and existing study. 
Finally, "Print Preview" and then "Print"  your Process Flow Diagram. 
 
Notes : 



3. Creating HACCP Instruction Cards 
 
3.1 The File Menu - Summary 
 

 

·  New - Start a NEW HACCP Instruction Card. 
·  Open - OPEN an EXISTING HACCP Instruction Card (from the 

"saved" HACCP Database). 
·  Save - SAVE the current HACCP Instruction Card (to the 

"saved" HACCP Database). 
·  Save As.. - SAVE the current HACCP Instruction Card as a 

NEW NAME (to the "saved" HACCP Database). 
·  Save As Web Page.. - Save the current HACCP Instruction 

Card as a Web Page. 
·  Print.. - Send the current HACCP Instruction Card to the 

PRINTER. 
·  Print Preview - See what the HACCP Instruction Card will look 

like when it is printed. 
·  Exit - Leave the HACCP Now program 
 

 

3.2 The Edit Menu - Summary 
 

 

·  Cut - Remove the currently selected text. 
·  Copy - Copy the selected text to the "Clipboard". 
·  Paste - Paste in the text from the "Clipboard" 
·  Hazards.. - Display and Edit the current "Source Database" of 

Hazards. 
·  Control Measures.. - Display and Edit the current "Source 

Database" of Control Measures. 
·  Critical Limits.. - Display and Edit the current "Source 

Database" of Critical Limits. 
·  Monitoring Procedures.. - Display and Edit the current 

"Source Database" of Monitoring Procedures. 
·  Corrective Actions.. - Display and Edit the current "Source 

Database" of Corrective Actions. 
·  Responsible Persons.. - Display and Edit the current "Source 

Database" of Responsible Persons. 
·  Hazard Control Resources (Graphics).. - Display and Edit the 

current "Source Database" of Hazard Control Resources. 
·  Protective Clothing Required (Graphics).. - Display and Edit 

the current "Source Database" of Control Measures. 
 
Note : It is recommended that data is only deleted from the " source 
database"  when absolutely necessary, as this is a knowledge base 
and ALL KNOWLEDGE IS USEFUL sooner or later. 

 



3. Creating HACCP Instruction Cards 
 
3.3 The View Menu - Summary 
 

 

·  HACCP Terms of Reference ± Select to move to HACCP 
Terms of Reference View, (i.e. to switch to it). 

·  Process Flow Diagram - Select to move to Flow Diagram 
View, (i.e. to switch to it). 

·  Show Instruction Card - Selected when in Show Instruction 
Card view. 

·  Main Menu - Select to go to Main Menu view, (i.e. to switch to 
it). 

 
Note : When you move between different " views"  your data remains 
loaded and will (normally) be there when you return unless you have 
cleared it. 

 

3.4 The Mode Menu - Summary 
 

 

·  Build Database - Stores the new relationships created, as you 
work, when you select information that is not already related. 
This then builds "knowledge" and speeds up decision making in 
the future. 

·  Edit Step - Allows editing / building of a HACCP Instruction 
Card without adding new relationships. Use mainly when you 
are editing an existing process step. 

 
Note : To get the most out of HACCP Now you should operate in 
"Build"  mode when writing new HACCP Process Steps and operate 
in "Edit"  Mode when editing a card which has already been built. 



3. Creating HACCP Instruction Cards 
 

3.5 Procedure for Creating a HACCP Instruction Card. 
 
1. Create a Process Flow Diagram, as described in Section 2, ªCreating a Process Flow Diagramº. 
 
2. At the Process Flow Diagram Screen Select "Navigate" Mode in the Mode menu. 
 
3. Decide which of the Process Steps you wish to create a HACCP Instruction Card for and simply 
"click" on it. The program will now load the current Process Title and Process Step name across to the 
blank HACCP Instruction Card screen, after checking that the Title and Name do not exist already. If, 
when the HACCP Instruction Card displays, it has data in its description and Hazards, etc, then the 
Study Name and Step details have already been entered. 
 
Note - You will be warned that if there is a currently loaded HACCP Instruction Card and you have not 
saved it that you should do so; if you do not then any unsaved work will be unrecoverably lost. 
 
4. When you arrive at the "blank" HACCP Instruction Card screen you should type in a description for 
the Process Step. Here you should be as accurate as possible and, in particular, describe things, or 
events, that have a positive or negative effect on Product Safety and Quality. Regard should be given to 
times, temperatures, packaging, people, machines, etc.,. There is a maximum space allowed of around 
400 characters, so if you find that no more words appearing even though your are typing then you have 
exceeded the maximum and should re-phrase in a less "wordy" manner. 
 
5. Having entered the description you should ensure that the Hazard Number is at No1 (this is located 
near the bottom and to the left of the Hazard "Possible Causes" text box on the Hazards Tab of the 
form) (if not move it to No1 by clicking the "Up" and "Down" buttons to the left of the Hazards). Next 
"click" on the type of hazard in the area marked "Hazard Selector", i.e. All Types, Microbial, etc., this 
will fill the hazard selector drop down list (Note: the list can be "filtered" by a phrase, e.g. "temp" or 
"residue"). Now click the "down arrow" on the right of the hazard selector and you will see a drop down 
list of all the Hazards that exist in the "Source database" which fit the filter and option button criteria 
selected. They are ordered alphabetically and by hazard type. Scan down the list to see if the Hazard 
you have identified already exists, this is most useful because if it does then there could be Control 
Measures and other data already associated with the Hazard that you can use. This process means 
you will save time and you will also be consistent throughout your HACCP study. If you see the Hazard 
you want select it in the list, if not type in a new hazard and click the "Select" button and you will be 
prompted to add the new hazard to the database if you are running in "Build" mode. Note - Always scan 
the existing Hazards first, rather than adding duplicate Hazards to the database. 
 
6. After having selected a Hazard you should now click the "Select" button. This will select the hazard 
and copy it across to the Hazards text box and at the same time this will clear any data from the CCP 
Decision Tree question drop down lists. 
 
7. Next you will need to complete the hazard analysis. To see each of the Codex Decision Tree 
questions hold the mouse pointer over the label for each question and the question will appear. Answer 
each question and the CCP will be determined automatically. 
 
8. At this stage you will need to decide if you wish to use the Safety Risk Significance (SRS) Factor 
determination area. To get there you will need to click on the "Hazard Analysis / Safety Quality Matrix" 
tab. Once there simply select Quality or Safety and then answer each of the questions for Severity and 
Risk. The SRS Factor is automatically determined and will prefix the Hazard when printed or Saved as 
a Web Page. 
 



3. Creating HACCP Instruction Cards 
 

3.5 Procedure for Creating a HACCP Instruction Card. 
 
9. Having completed the Hazards section we are now ready to proceed to the Control Measures 
section. This is achieved by clicking on the "Control" tab. Once in the Control area, notice that the 
current hazard is displayed at the top of the area and that the procedure for selecting a Control 
Measure is very similar to that of selecting a Hazard. Again if you wish to add a new piece of data you 
should simply type it into the Control Measure selector drop down list and click on "Select". This will 
then allow the new Control Measure to be added to the Source database and then associated with the 
currently selected hazard. 
 
10. If you chose not to use the SRS system to quantify the Severity and Risk of the Hazard you will be 
reminded about this but are free to proceed at the Control Measures tab. 
 
9. Each Control Measure will always have a "Hazard Control Resource" (Graphic) associated with it as 
well as a "default responsible person". The "Hazard Control Resource" for the particular Control 
Measure will automatically be displayed in the "Hazard Control Resource" tab area of the screen, which 
you will need to see. You can choose to accept this graphic or choose another by selecting one in the 
drop down list. You MUST, however, enter a caption for the "Hazard Control Resource" by typing in a 
short description of what the "Hazard Control Resource" (Graphic) represents. Critical Limit, Monitoring 
Procedure and Corrective Actions don't have graphics associated with them but do have a "default" 
responsible person associated with them. Again, the responsible person automatically displayed, as 
with Control Measures, can be accepted or changed to another in the list, or a new one entered (which 
will be added to the database). 
 
10. After completing the Control Measure data for the Hazard you can now select a Critical Limit, 
Monitoring Procedure and Corrective Action in a very similar way to the selection of a Control Measure. 
This time, however, the information is related to (or associated with) the Control Measure (i.e. NOT the 
Hazard) and as such any data selected will be check to see, firstly, if it exists and, secondly, if it is 
related to the Control Measure. If the Critical Limit, Monitoring Procedure or Corrective Action either 
don't exist or are not related you will be prompted to "set the data" up by selecting a default responsible 
person, etc. if running in "Build" mode. 
 
11. On saving your work, if you have not already done so, you will be asked to enter Issue and 
Document information. This is very straightforward and can be done at the Document Control tab on the 
screen. You should type in the required information at the bottom of the screen. Note, that you can 
enter multiple Document Amendment information here. This is very useful because it can be used as an 
audit trail and during review / verification activities. 
 
12. To enter "Protective Clothing Required" or GMP graphics click the GMP tab and you will see two 
lists. The list on the left is a list of Protective Clothing [Graphics] "Available", whilst the one on the right 
is the list of Protective Clothing [Graphics] "Selected". Simply select graphics on the left and press the 
right pointing hand (or double click the graphics on the left) to move the required items over into the 
"Selected" list. When you have the graphics you require in the right hand list click the "Load" button and 
they will be displayed from left to right in the order they appear (top to bottom) in the "Selected" list. To 
change the order select a graphic and use the "Up" and "Down" buttons to the right of the selected list 
and then re-click "Load" to display the new order. Graphics can be removed from the "Selected" list if 
desired by selecting the item to be removed and clicking the left pointing hand (or by double clicking the 
graphics in question). 
 



3. Creating HACCP Instruction Cards 
 

3.5 Procedure for Creating a HACCP Instruction Card (cont'ed). 
 
13. Finally, the training section contains a very powerful tool for maintaining traceability of staff working 
at Process Steps as well as the training they have had. To add / edit new employees click on the "Add" 
button and a screen will pop up asking you for the required information. Complete the required 
information and select Add or Next to add another record. When you have finished this task you will be 
asked if you wish to associate the newly entered employee with the current process step. Answer as 
appropriate, you can always associate them later. 
 
14. To add / edit an employees training records click on the "Records" button and the top part of the 
screen will contain the employee list which can be navigated using the arrows. The bottom part of the 
screen will show the training record for the employee. Everything here is fully editable with the 
exception of system ID numbers. 
 
KEY POINTS TO NOTE : 
 
·  Once you begin entering information for a Hazard you MUST complete that information right 

through to Corrective Actions. This is a requirement because of the potential for missing out vital 
information that could lead to a food safety problem. 
 

·  Each Control Measure has an associated "Hazard Control Resource" (Graphic). This Graphic is 
automatically loaded in whenever an existing Control Measure is selected and a caption MUST be 
entered for it, by typing underneath the "Hazard Control Resource". 

 
·  A HACCP Instruction Card must have a Title, Step Name and Number as well as Issue Information 

fully completed (in addition to the HCR captions mentioned above) before it can be saved. This 
ensures there are no crucial gaps left in the HACCP data. 
 

·  Remember that you can "Print Preview" at any time to see what the HACCP Instruction Card looks 
like by selecting File>Print Preview or clicking on the Print Preview icon. 
 

·  HACCP Instruction Cards are saved (along with the Flow Diagram information) to the "HACCP 
Database". 
 

·  Individual Hazard, Control Measure, Critical Limit, Monitoring Procedure, Corrective Actions and 
Responsible Person as well as Graphics data and all their associations (relationships) are saved to 
the "Source Database" when running in "Build" mode. 



3. Creating HACCP Instruction Cards 
 
Tutorial 2 - Creating HACCP Instruction Cards 

 
The following tutorial will demonstrate most of the areas used in the creation of SHOW Instruction 
Cards. 

 
Scenario 
Your customer has also asked to see the HACCP information for the Process Flow diagram 
generated earlier. Produce at least TWO HACCP Instruction Cards for the diagram generated 
earlier, including the following information: 
 

·  At least ONE of EACH HAZARD TYPE 
·  A NEW HAZARD that you added yourself each with an SRS Factor 
·  A new Control Measure for an EXISTING HAZARD 
·  At least ONE new item from the following list, Critical Limit, Monitoring 

Procedure, Corrective Action, Responsible Person, 
·  Save your HACCP Instruction Card when finished. 
 

When you have finished save the HACCP Instruction Card and then select "File>New" to clear it 
and then "File>Open"  to load the newly created HACCP Instruction Card back in again. This will 
prove that you have saved your HACCP Instruction Card and illustrate how to "Open"  and 
existing HACCP Instruction Card from the HACCP Instruction Card screen. Finally, "Print 
Preview" and then "Print"  your HACCP Instruction Card. 
 
Notes : 
 

 



4. Using the HACCP Now Training Pack 
 
4.1 Procedure for Using the HACCP Now Training Pack. 
 
1. The Training Pack is very straightforward to use and is based on Microsoft PowerPoint 
presentations. If you have PowerPoint on your PC you can edit and change these training presentations 
to suit your circumstances, country and / or industry. There are normally four standard training packs 
that come with HACCP Now; these are: 
 

1. “ The Good Food Hygiene”  training course, 
2. “ An Introduction to HACCP and Hygiene”  and, 
3. “ The Principles of HACCP”  – a complete training presentation on the Principles of HACCP. 
4. The “ HACCP Now Fast Track Learning Pack” , of which this document forms part of. 

 
2. To start any of the required presentations simply start The HACCP Now program and click on 
HACCP Now Training Pack, or select View>Main Menu if you happen to be at either the Flow Diagram 
or HACCP Instruction Card screens. 
 
3. Then read the list of presentations available and press the appropriate button. The presentation will, 
after a few seconds, start up in slide show mode and allow you to then navigate through it using the 
action buttons. 
 

Tutorial 3 - Using The HACCP Now Training Pack 
 

The following tutorial will demonstrate how to start and navigate through the HACCP Now Training 
Pack 

 
Scenario 
Your customer has asked, whilst on site, to see what training you are doing with your food 
handling staff and is particularly interested in the Food Hygiene training pack. Demonstrate how 
to start up the training pack from within the HACCP Now. 
 
 
Notes : 
 
 



 

5. Using the HACCP Now WWW Resources 
 
5.1 Procedure for Using the HACCP Now WWW Resource. 
 
1. The HACCP Now WWW Resources requires connection to the Internet, either via a modem or via 
the company's' computer network system. 
 
2. The Internet is a vast resource and contains much information which can be used by HACCP Teams 
when researching or looking for information on Hazards, Control Measures, etc, Microbes, 
Legislation,,,...the list is endless. 
 
3. The HACCP Now WWW Resources is an area of the Internet organised by HACCP Now for users of 
The HACCP Now in particular. This saves you having to search books, magazines and the internet for 
information. 
 
4. The Internet is made up of "Pages", just like a book. Each "Page" is linked (or cross referenced) to 
another page by some word(s), picture, or phrase. These are called "Hyperlinks" and are usually blue 
underlined like this. When a "Hyperlink" is clicked on it takes to a new page (or a new part on the 
existing page). The new page could be on the other side of the world or in a computer within your own 
company. 
 
5. Because of the huge amount of information available there are "Search" engines. These search for 
key-words or subjects for you and help filter out all the pages you don't want to see. 
 
6. The HACCP Now Web Site contains common Search Engines as well as Hyperlinks to various 
Hygiene, Food Safety and HACCP resources. 
 
 

Tutorial 4 - Using The HACCP Now WWW Resources 
 

The following tutorial will demonstrate how to start and navigate through the HACCP Now WWW 
Resources. 

 
Scenario 
Your HACCP Team has had a meeting and you have been asked to go away and get as much 
information of Staphylococcus aureus as possible. You are going to use the Web for speed and 
the  HACCP Now WWW Resources in particular. You need to carry out the following : 
 
·  Find information at the HACCP Now Web Site on the bacteria in question. 
·  Use two search engines to search for other information on the bacteria. 
 
 
 
Notes : 



6. Publishing your HACCP Data to the Web 
 
HACCP Now allows an entire HACCP Study to be saved as a set of Web pages and can be used in 
conjunction with the Document Linking (available only in the Enterprise Version, see section 8.0) to 
publish and entire HACCP Study to your Intranet or even the Web. This is achieved in two distinct 
ways: 
 
1. From the File menu at the Process Flow Diagram screen - this allows the entire HACCP Study 
(and any Document Links) to be saved and the system will create a "clickable" map based on the 
Process Flow Diagram which acts in the same way as "Navigate Mode", except in a Web Browser in a 
read only mode. 
 
Procedure to "Save As Web Page"  from Process Flow Diagram: 
1. Load in a fully completed study into the Process Flow Diagram screen by clicking File>Open or by 
clicking on the Open Folder speed icon, 
 
2. Click File>Save As Web Page, 
 
3. You will be prompted to Save the data first. This ensures that whatever you publish to the Web is the 
same as the information stored in your database, 
 
4. The system will then prompt you to select a folder to store your HACCP information in, it is a good 

idea to create a new folder for each study (this can be achieved by clicking on the  icon in the 
windows file dialog). It is strongly recommended that you allow the system to choose the study and 
page names for the study, this will be automatically completed for you and all you need do is select 
where (i.e. which folder) you wish to save the information to and click "Open", see below : 
 

 
 

5. The system will now run through each page and each underlying HACCP Instruction Card and save 
them as a Web Page linked directly from the "clickable" map generated for each page, 
 
6. When complete the HACCP Now will prompt you to see if you wish to view the newly created 
HACCP Web Pages, selecting yes will display them in your systems default Web Browser, 
 
7. To navigate through the HACCP Study simply click on the required Page Number at the top of the 
page and click on the Process Step you wish to view. 
 



Note: If you wish to store these pages for viewing on the Web, or on your organisations Intranet, you will need to 
copy ALL files from the folder you saved them in. For this reason it will be a good idea if you create a new folder 
with the same name as the HACCP study (see step 4. above) to store all your Web Page information in. 



6. Publishing your HACCP Data to the Web (Cont'ed) 
 
2. From the File menu at the HACCP Instruction Card screen - This functionality allows you to 
create individual HACCP Instruction Cards and is useful for updating Web Pages individually. 
 
Procedure to "Save As Web Page"  from HACCP Instruction Card: 
1. Load in a fully completed HACCP Instruction Card by selecting File>Open or by clicking on the Open 
folder speed icon, 
 
2. Select File>Save As Web Page in the file menu, 
 
3. The system will prompt you to save the HACCP information first to ensure that the database and the 
Web Page to be created both contain the same information, 
 
4. The windows file dialog will appear, navigate to the folder you wish to save the HACCP Instruction 
Card Web Page to and select Open. It is strongly recommended that you use the name that the 
system puts in for you here as this means that the system will automatically "link" up with the parent 
Process Flow Diagram, see below:  
 

 
 

5. After the Web Page has been created HACCP Now will prompt you to view the new Web Page, 
select Yes if you wish to do so, 
 
6. The new Web Page will be displayed, 
 
7. To check that the link between the Process Flow Diagram, (if there is one), is working correctly you 
will need to open up the parent Process Flow diagram from the folder saved to and open the relevant 
page on the Process Flow Diagram and click on its Process Box. 
 



7. Customizing HACCP Now 
 
HACCP Now can be completely Customised. This means that all screens, text on screen, text in 
databases, the hazard safety, risk significance questions can all be changed to either a different 
language from English or simply different terminology for various industries. 
 
HACCP Now allows customisation of the following: 
 
1. Forms - These are the screen windows of the system. You can change the Title, Background Colour, 
Height and Width of the form. 
 
2. Menus - These are the drop down menus at the top of the Form as well as the pop up menu's when 
you right click on a form. The text that appears in these menus can be changed. 
 
3. Labels - These are the text labels commonly used to explain what fields to be completed are, etc. 
The Caption (i.e. text used), Foreground Colour  (i.e. text colour) and Font (Font, Style, Size) can all be 
changed to suit. 
 
4. Buttons - These are used to take actions on the Forms of the system. Each of these can have their 
Text, Button Background Colour, Height, Width and X, Y Co-ordinates (position on the screen) 
changed. In addition the Font (Font, Style, Size) can be customised to suit. 
 
5. Options - These are the "radio buttons" of the system and HACCP Now allows the user to change 
the Text associated with the Option as well as the Height, Width and X, Y Co-ordinates (position on the 
screen). In addition the Font (Font, Style, Size) can be customised to suit. 
 
6. Drop Down Lists - These can be customised only when they contain fixed data, e.g. in the HACCP 
Instruction Card builder the user can select from a set of pre-defined questions which determine the 
level of risk and the impact of the hazard. HACCP Now allows the Text of these to be altered and the 
Font (Font, Style, Size) to be Customised. 
 
7. Tool tip Texts - These are text helpers which appear when the mouse pointer is "hovering" over a 
button or text field. They are designed to help the user understand what the individual buttons, etc do 
on each Form or screen. The text of these can be changed for every Form which has them. 
 
8. Tab Strips - These are tabbed dialogs that appear on only a few on the Forms in HACCP Now. 
Tabbed dialogs are similar to the "tabs" that stick out of an organiser type book and the help the user 
get to the area they want quickly. The text on each Tab can be change to the users requirements. 
 
9. Data Grids - These are grids (similar in appearance to Excel or some other spread sheet) that are 
used to display and / or enter data into the system. The overall Grid Caption together with the individual 
Column Captions can be changed to suit the users needs. 
 
10. Frames - These are the box like areas inside which Labels, Text Fields and Buttons are place. The 
Frames provide a visual means of letting the user know that everything inside the frame works together 
in some way. 
 
11. System Messages - Each Form and, indeed, the system as a whole has a number of Messages 
that provide information and report errors. The user can control the text and layout of these messages. 
 
The above represent almost everything that could possibly be customised in HACCP Now. Together, 
this functionality means that HACCP Now is not just a Food Safety system. It is now a multi-lingual, 
multi-process, analysis tool that assesses hazards and identifies Critical Points in Processes. 



 
7.1 How to Customise HACCP Now: 
HACCP Now allows the user to Customise as much or as little as is needed. This means that you can 
Customise some, or all, of any of the items mentioned earlier. 
 
There are two ways to Customise HACCP Now. These are: 
 

1. Right click on the form you wish to Customise (or select the Edit menu and then Customise 
at the screens with Menu's). 
 
2. Customise any item from the "User"  part of the system. 

 
We shall look at each method in turn. 
 
7.1.1 Right click on the form  
There are two methods with which you can Customise HACCP Now using this method. If a screen has 
a Menu at the top of the form click ~Edit>Customise and select the item you want to change Or right 
click on the form background and choose the item you wish to customise. 
 
This method allows the user to Customise only the areas that they work with most frequently and is 
useful when the minimum amount of work is to Customise the system is a requirement. It is also a very 
simple way to carry out this work. The procedure is as follows: 
 
1. Open up the form you want to Customise by clicking on a button, menu item, or carrying out an 
action that calls the form. When the form you wish to Customise is displayed right click on the 
background of the form. A pop up menu will appear as below: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
2. Using the left mouse button, click on the item you wish to Customise. The relevant Customisation 
form will appear. For our example we will use the buttons Customisation form. The buttons 
Customisation form is shown overleaf: 

A pop up menu appears 
when right clicking on 
any form in HACCP 
Now. 



 
 
The buttons Customisation form 

 
 
The form above is typical of all the Customisation forms in HACCP Now. The name of both the form 
and the buttons (or any item for that matter) are for reference only. The customisation profile drop down 
list shows the default Customisation profile. When the user clicks the "Save" button, the information on 
the form is saved to the profile displayed. 
 
The user can add a new profile from any Customisation form by clicking on the "New Profile" button. 
This displays the New Profile form as below: 
 

 

button caption (use the 
"&" symbol before the 
letter you wish to use 
as an "ALT" keyboard 
shortcut. 

The form name to 
be customized. 

current 
customization 
profile name 

create a new 
customization 
profile 

Select the font, style and size 

Enter the height and width 
of the button along with its 
Top and Left co-ordinates 
(these always apply to the 
top left hand corner of the 
component) 

button name 

button 
background 
colour 

close the 
customization form 
(without saving recent 
changes) 

apply the current 
changes to the form 
being customized 

save and apply 
the current 
changes to the 
form being 
customized 

Scroll bar for 
long lists 



 
To add a new profile simply enter in its name and some optional comments and click Save. The new 
profile will be added to the Profile selection drop down list. 
 
3. Select the Customisation profile you wish to save the details to by clicking in the Profile drop down 
list and then make the changes you require and click the "Save" button. If Customisation data for the 
component, form and profile already exists if will be overwritten (after warning the user). If not, then the 
new Customisation information will be added to the Customisation database. Theoretically, there is no 
limit to the number of Customisations that can be created. 
 
4. The "Apply" button can be used to see how the Customisation you are working on looks on the form 
in question. This is only of use when you have right clicked to load the Customisation form. This 
functionality allows the user to drag the Customisation form out of the way (or minimize the form) in 
order to see the effects of the Customisation so far. 
 
5. When your Customisation has been saved click the "close" button to close the form. The new 
Customisation is applied immediately. 
 
7.1.2 Customise any item from the "User"  part of the system 
The alternative method of Customisation can be carried out from the "User" form. To get to this area of 
the system, click on "User" at the main start menu of HACCP Now. Once the form is displayed a 
Customisation button is available in the middle of the form. Click on the "Customise" button to display 
the "Customisation Control Panel" as shown below: 
 

 
 
This allows the user to Customise any of the objects in HACCP Now. Simply select the profile to save 
the new Customisation information to (or click "New Profile" to create a new one) and select the object 
name you wish to Customise (this mainly refers to the form with which the item you want to change is 
associated). Finally select an item you want to Customise, e.g. buttons, text labels, buttons, and then 
click "Customise. This action displays the relevant Customisation form that can be used to change the 
details as described previously. 
 
Note: The "Apply" button will not display the form Customisation as in the above example using this 
method, as the form in question is not actually displayed. 
 
7.2 Setting The Default Customisation Profile 
The default Customisation profile is user specific. This means that each user can have their own 
Customisation profile if required, or they can all use the same one. Setting this property is simple: 
 
1. Once a Customisation profile has been created each user can log in and select the "User" option 
from the main start menu. 
 



2. If there are several users of the system, the user may have to navigate to their details. This can be 
achieved by clicking on the navigation buttons at the bottom of the form until the users' details are 
displayed. 
 
3. In the upper right corner of the User form the current default Customisation profile for the selected 
user is displayed.  This can be changed easily by selecting the "Change Profile" button. When clicked 
the Change Profile form appears and the user can select a new Customisation profile to apply to the 
system. 
 
Notes: 

1. If you have already been working in the Flow Diagram and HACCP Instruction Card part of the 
system then you may be required to re-start the system before the new profile will be applied. A 
way round this is to change the profile as soon as you start HACCP Now (i.e. before opening 
the Flow Diagram or HACCP Instruction Card screens'). 

 
2. When you login to the system at the start, if you choose your language then the system will 

automatically use the profile selected and will set that as your default profile for the login 
session. 

 
7.3 Special Notes regarding System Messages 
The System Messages in the system have special formatting and data elements in them that you must 
keep if you wish the correct information to be displayed. 
 
For example: 
 
VbCrLf ± is a special system word that means ªnew lineº. You can use this word to tell the system to 
make place a new line in order to break up long sentences and make the message more readable. 
 
Err.Number ± This is used to pass in some numeric information, such as a number. These should 
be left in the new translation / customisation you make. 
 
Err.Description ± This is used to pass in some text information, such as a filename or description of 
some sort. These should also be left in the new translation / customisation you make. 
 
Conclusion: 
HACCP Now©s powerful Customisation features enable the system to be Customised in any language 
and industry combination. The system can be Customised as much, or as little, as required, making 
HACCP Now a very straightforward and simple system to Customise. 
 



 

8.0 Document Linking with HACCP Now . 
HACCP Now has Document Linking facilities that mean the system can be linked into all manner of 
existing HACCP Documentation. When used in conjunction with the ªSave As Web Pageº functionality, 
HACCP Now provides a completed ªHACCP-Centricº Document Management System. This means that 
instead of maintaining many different ªmanualsº consisting of printed paperwork you can now manage 
all your HACCP, Pre-Requisite, GMP and Quality information in one central place. 
 
The Document Links screen can be accessed directly from the loaded HACCP Instruction Card from 
the ªLinksº Menu and is shown below: 
 

 
 
Using the Document Links feature the user can associate one or more Documents of ANY type with the 
HACCP Study at any of the following levels: 
 

·  The HACCP Study itself ± useful for other information relating to that Process or Product as a 
whole. An example of use here may be a link to a plan of the Production Line. 
 

·  The HACCP Process Step ± useful for linking to and publishing of Step Specific information or 
data, such as Work Instructions or Standard Operating Procedures. 
 

·  The currently selected Hazard ± this can be used to explain the rational behind the selection of 
that hazard, possibly describing why the hazard was selected, the precise nature of the 
hazard and more. 
 



·  The currently selected Control Measure ± this may explain the nature of the Control Measure 
and perhaps why it was chosen and why it is effective. 
 

·  The currently selected Critical Limit ± perhaps to explain why the Critical Limit was chosen and 
reference other information that was used to select that Critical Limit. 
 

·  The currently selected Monitoring Procedure ± this can be used to link not only to the actual 
Procedure itself but any data that is captured as a result. 
 

·  The currently selected Corrective Action ± this link can contain the detailed procedures that 
are to be followed in the event of Corrective Action being required. 

 
Creating Document Links is easy, simply click on the relevant ªLinksº button and then the screen will 
change to one like that below: 
 

 
 
To Add a Document Link simply click the ªAddº button and then use the screen overleaf to enter a 
Document title, select the document itself (the Document selected can be anywhere on the PC or 
network, but it is good practice to keep your documents in a central place with a good folder structure). 



 
 
The Document Name is the title you wish to see displayed in the ªPublishedº Document Management 
System. The Document Location is the ªmaster documentº that you update and work with. The 
Document Type is a text field that all documents are ªGrouped byº on the Published page, e.g. Policies, 
Procedures, Instructions, Checklists, etc. the Document Description is some summary text that is also 
ªPublishedº on the resulting page in the Document Management System. 
 
Clicking Save will save these details to the database for the Study, Step, Hazard, etc., but this does not 
mean that the Document is automatically ªpublishedº. For that to happen there are two actions that 
must be taken as follows: 
 

1. The ªpublish flag must be set ± to do this click the ªpublishº check box next to the documents 
you wish to publish (see screen on previous page). 
 

2. The Study (or Step) must be ªSaved as a Web Pageº ± this option is available at the Process 
Flow ªFile>Save As Web Pageº menu OR the HACCP Instruction Card ªFile>Save As Web 
Pageº menu. This process is described in detail overleaf. 

 
Once a document link has been saved you can return to this screen to work with that document. 
Clicking on the blue hyperlink on the screen will prompt you if you wish to View the Document or Edit 
the Document Link record. This is a convenient way of managing all your documents and ensuring that 
only ªliveº documents are published into your company’s procedures.



Publishing your Document Management System 
In order to ensure that all the documents and information you expect to see are published you must 
ensure that the ªpublishº flag is selected and then click the ªSaveº button, see below: 
 

 
 
Following this you have two options as follows: 
 

1. Publish only the information for this step ± for this use the ªSave As Web Pageº from the 
HACCP Instruction Cards screen 

 
2. Publish the entire HACCP Study ± for this use the ªSave As Web Pageº from the Process 

Flow diagram screen 
 
For more detail on ªSave As Web Pageº see section 6.0 of this document. 
 
Conculsion: 
HACCP Now helps you make best use of existing information and can help manage all the 
documentation and data required for your company’s production operations. If used well, this feature 
will save you many hundreds of man-hours and make it easy for everyone in your organisation to stay 
up to speed with Policies, Procedures, Instructions, Checklist data and more. 


